Support Emails Not Working

Incident Report for SMS Broadcast

Resolved

This incident has been resolved.
Posted Mar 02, 2026 - 14:50 AEDT

Update

We are continuing to investigate this issue.
Posted Mar 02, 2026 - 13:24 AEDT

Investigating

We are currently experiencing issues with emails sent to all support addresses.

In the meantime, please contact Support via Live Chat until the issue is resolved.

Our IT team is working on this as a priority and will provide updates as soon as they become available.
Posted Mar 02, 2026 - 11:22 AEDT
This incident affected: Other Issues.