Contact centre phones unavailable
Incident Report for SMS Broadcast
Resolved
Our phones are back up, and our contact centre staff are taking calls again.

Thanks for your patience.
Posted over 1 year ago. Nov 23, 2017 - 11:29 AEDT
Monitoring
Our phone provider is experiencing an outage, affecting all inbound and outbound phonecalls from our contact centre. We are still providing full email and online chat support. If you need to contact us, please contact us via any of the following methods:

- By emailing contact@smsbroadcast.com.au
- By completing the Contact Us forms in our members area, or public website
- By going to our public website and using the web chat interface

We will update this notice as soon as our phone lines are restored.
Posted over 1 year ago. Nov 23, 2017 - 09:50 AEDT